Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 15, 2026 - 00:00 UTC
Scheduled
A general maintenance is planned from Sunday 15/2 01:00 AM to 11:00 AM (Brussels time). During this time no transactions (transfer, assign, ..) are possible in the production environment.
Posted Feb 10, 2026 - 11:45 UTC
This scheduled maintenance affected: SCR Production (SCR Web Application, SCR Admin Application, SCR Production Blockchain Network).